Which versions of Outlook are supported?

Jul 2, 2010 at 1:52 PM
Hi, Which versions of Outlook are supported?
Coordinator
Jul 22, 2010 at 4:07 PM

should work in 2003 and newer.